Mail d’alerte non reçu

SP2013


Bonjour à tous,

Aujourd’hui je vais vous parler d’une problématique pouvant survenir lors que vous définissez des alertes pour des utilisateurs.

L’erreur en question provient du fait que l’utilisateur reçoit le mail disant qu’une alerte a été créée pour lui mais qu’il ne reçoive pas les alertes générées par l’ajout/modification d’élément.

Une des raisons peut se trouver si vous configurez les logs en « Verbose » pour la catégorie « Alert ».

Pour configurer les logs de cette manière, suivez cette procédure :

  • Aller dans la centrale d’administration
  • Cliquer sur le lien « Monitoring»
  • Dans la section « Reporting », cliquer sur le lient « Configure diagnostic logging»
  • Dans la section « Event throttling », faites un expand de la section « SharePoint Foundation » et sélectionnez « Alerts»
  • Dans la liste déroulante « Least critical event to report to the trace log » choisissez « Verbose »
  • Cliquer sur ok

Note : cette opération ne provoque pas de recycle ou de IISRESET, il peut être fait en live sur une ferme de production sans soucis. Par contre dès que vous avez fini votre test, n’oubliez pas de revenir à l’état précédant de configuration (en choisissant « Reset to default » dans la liste déroulante, sous peine de voir vos fichiers de logs grossir énormément).

 

Cette configuration vous permettra de voir des entrées de ce type

“Alert for Immediate subscription {GUID}, event ID, USERNAME succeeded permissions check”

Si au contraire vous voyez des entrées de ce type

Alert for Immediate subscription {GUID}, event ID, user USERNAME failed permissions check

Vous avez votre coupable!

En effet, lors de l’envoi d’une alerte, un test est fait au préalable afin de savoir si l’utilisateur peut s’identifier sur le site! Si vous n’avez pas encore donné l’accès à l’utilisateur, celui-ci recevra bien le mail lui disant qu’une alerte a été créée pour lui mais ne recevra pas les alertes effectives!

En espérant que ca aide,

Christopher.

Cet article, publié dans SharePoint 2010, SharePoint 2013, est tagué , . Ajoutez ce permalien à vos favoris.

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s